SM Brass only sporadically working in Kontakt/Reaper

I'm having unreliable performance running Kontakt instruments through Reaper on Windows 10.



Specifically, the Samplemodeling brass set. I bought them on Monday and have spent all week trying to get them to work with (almost) no success.



I have confirmed that the breath controller I am using (TEControl Breath & Bite 2) and my keyboard controller are sending their respective signals to my DAW. I switch the instrument to breath controller mode and confirm it is listening for the correct CC. I switch the MIDI channel to "omni" just to be sure. But when I try to play, not a sound. Keyboard mode, breath controller mode, toggle MIDI channels, remap CCs, nothing has proven effective. For a glorious few minutes I got a single French Horn instance to work, breath controller and all, but then I tried to add a second, and it didn't work. Then I removed both and started fresh. Nothing worked, and I haven't been able to play the instruments since.



I suspect it's an issue with Kontakt (or my failure to operate it), because I previously had similar trouble with the only two other Kontakt-based instruments I use, FluffyAudio's SimpleFlute and AudioThing's Organetta. They worked only sporadically, and one day while SimpleFlute was working, I saved a Reaper track template with the complete FX chain setting stored so I could recall it. This is now the ONLY way I can reliably run this instrument.



I've tried loading SimpleFlute from the track template and then loading a separate instance manually to compare their settings. For the life of me I cannot find ANYTHING different between the two. Yet, only the template works.



It's worth noting, I think, that I only encounter these issues in Kontakt. I've had Komplete 11 for several months now, and instruments that run in Komplete run flawlessly. But instruments that must run in Kontakt...seldom do.



I would greatly appreciate any suggestions. I'm sure I'm missing some detail, but I just can't spot it.

Comments

  • edited 5:05AM
    I also use The Trumpet on Reaper with a BBCv2. I also do have issues, while I don't have any problems with other Kontakt instruments, such as Pianos, Organs or Audio Modeling Flutes and Cello. There is another Trread in this forum on that topic. SampleModeling promised to take care of this with the nexxt version of The Trumpet, but no date for this is announced.



    But I never had a "No sound" issue, just dropping notes in certain instances (see the other thread).



    For the time being I did a reaper JSFX script that helps a lot, but is not perfect.



    You might want to try it:
    </s><i> </i>desc:MIDI Trumpet Bugfix //tags: MIDI processing filter //author: MSchnell @init CC_MSG = 0xB0; // 11; EXPRESSION = 2; NOTE_ON = 0x90; NOTE_OFF = 0x80; minnote = 52; maxnote = 84; notes = 0; notescount = maxnote - minnote + 1; killed = 0; e0 = 0; @block while (midirecv(mpos, msg1, msg2, msg3) ) ( statusHi = msg1 & 0xF0; channel = msg1 & 0xF; (statusHi!=0xF0) && statusHi ? ( // Time code etc // x = StatusHi; mute = 0; statusHi == CC_MSG ? ( // CC Message msg2 == EXPRESSION ? ( msg3 ? ( e0 = 0; // expression &gt; 0 killed ? ( killed = 0; i = minnote; loop (notescount, vel = notes[i]; vel ? ( // notes[i] = 0; midisend(mpos, NOTE_OFF | channel, i, 0); midisend(mpos, NOTE_ON | channel, i, vel); ); i += 1; ); ); ) : ( e0 = 1; killed = 1; ); ); ) : statusHi == NOTE_OFF ? ( notes[msg2] = 0; !e0 ? killed = 0; ) : statusHi == NOTE_ON ? ( notes[msg2] = msg3; !msg3 ? ( !e0 ? killed = 0; ) : ( killed = 0; ); ); !mute ? midisend(mpos, msg1, msg2, msg3); ); ); <e>

    -Michael (Yesterday we recorded a first track with The Trumpet: still a lot of work to do with that song, but already sounds GREAT ! )
  • edited 5:05AM
    Yeah, my issue isn't individual notes dropping, it's Kontakt outright not receiving MIDI.



    Here is a screenshot of two separate flute instances, side by side: https://imgur.com/a/j8JPP

    (Not an SM product, but this is essentially the same issue I'm having with SM.)



    The left is the instance loaded from a Reaper track template, the "reliable" track. You can see here it is receiving MIDI. In the lower left you can see its Reaper track level receiving the MIDI (red line) and producing sound (yellow, of course).



    The instance on the right is loaded manually, and as far as I can tell, configured identically to the left. But it is clearly not receiving MIDI or producing sound. But it does have the red line on its Reaper track, showing that at least Reaper is receiving a MIDI signal.







    I registered before I realized this wasn't necessarily a problem with SM itself, more likely Kontakt or Reaper. And a mod at the NI forums is scratching his head, so I guess I'm off to the Reaper forums!



    Thanks for sharing the script. I'll keep it in my pocket in case it is a proper bug causing trouble.



    Sure hope I can get this fixed asap, I have been itching for days to dig into the SM brass!
  • edited 5:05AM
    farberhudkins wrote: so I guess I'm off to the Reaper forums!
    I was going to suggest exactly this :)

    See you there...

    Playing the Trumpet with the BBC is real fun !!!



    -Michael
  • edited 5:05AM
    A very common problem with using Reaper live is forgetting to activate the record monitoring (little loudspeaker symbol) in the track header or mixer.



    -Michael
  • edited 5:05AM
    MSchnell wrote:
    A very common problem with using Reaper live is forgetting to activate the record monitoring (little loudspeaker symbol) in the track header or mixer.



    -Michael


    Exactly this was the problem. I'd forgotten to save that detail into the track template I was using AND forgot to toggle it when starting a track manually. Fortunately, a mod at the Native Instruments forum caught it. :x



    The instruments works like a charm now!

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.